Problems with SS Default Templates

General ShopSite user discussion

Problems with SS Default Templates

Postby Vince Salese » Wed Feb 16, 2005 10:45 am

OK in a nutshell.
Page uses SS Default Page Template
Product uses SS Default Product Template
Sub Product uses SS Default Product Template

I added a simple sub-product which is a minor part for the product. It has
no More Info Page and is not a member of any page as a seperate product.

When I make it a subproduct of the product it belongs to, the products'
pricing disappears and is replaced with the sub-products Price and Add To
Cart button. The products More Information Page gets the same treatment.
When I remove the sub-product the products pricing format returns.

I could understand this if I were using custom templates and had something
haywire in one of them, but these are all using the SS Default Page &
Product Templates. Do I have currupted templates?

Thanks
vince@ahoycaptain.com
Vince Salese
 

Re: Problems with SS Default Templates

Postby loren_d_c » Wed Feb 16, 2005 11:49 am

The behavior you describe is the correct behavior for the subproduct
feature when using the default product template. The parent product is
not orderable but the subproducts are. If you are using the subproduct
feature but to do cross-sell instead so that you want the parent product
to also be orderable, you will need to create your own custom product
template.

-Loren


Vince Salese wrote:
OK in a nutshell.
Page uses SS Default Page Template
Product uses SS Default Product Template
Sub Product uses SS Default Product Template

I added a simple sub-product which is a minor part for the product. It has
no More Info Page and is not a member of any page as a seperate product.

When I make it a subproduct of the product it belongs to, the products'
pricing disappears and is replaced with the sub-products Price and Add To
Cart button. The products More Information Page gets the same treatment.
When I remove the sub-product the products pricing format returns.

I could understand this if I were using custom templates and had something
haywire in one of them, but these are all using the SS Default Page &
Product Templates. Do I have currupted templates?

Thanks
vince@ahoycaptain.com

loren_d_c
 
Posts: 2564
Joined: Fri Aug 04, 2006 12:02 pm
Location: Anywhere

Re: Problems with SS Default Templates

Postby jim » Wed Feb 16, 2005 3:34 pm

If a product is added as a subproduct of itself then the add to cart
link will be displayed. So just assign the product as a subproduct
along with the other products.

There are situation where this is the way you would want it to work for
example If you are selling various sizes of something like asprin then
you would want the main product (asprin) to have the description but no
buy button. The subproducts would be bottle of 100, bottle of 500 etc.
which would need the buy buttons. But you obviously couldn't buy
asprin by itself.

There are other situations where you may want the parent product to have
the buy button such as selling a printer with subproducts of toner,
paper, photo paper etc. Usually just adding the main product as a
subproduct will handle this situation and the default templates take
that into account. But if you need to have the main product have its own
buy button without being a subproduct then you would need to make a
custom template.

Jim
Vince Salese wrote:
OK in a nutshell.
Page uses SS Default Page Template
Product uses SS Default Product Template
Sub Product uses SS Default Product Template

I added a simple sub-product which is a minor part for the product. It has
no More Info Page and is not a member of any page as a seperate product.

When I make it a subproduct of the product it belongs to, the products'
pricing disappears and is replaced with the sub-products Price and Add To
Cart button. The products More Information Page gets the same treatment.
When I remove the sub-product the products pricing format returns.

I could understand this if I were using custom templates and had something
haywire in one of them, but these are all using the SS Default Page &
Product Templates. Do I have currupted templates?

Thanks
vince@ahoycaptain.com

jim
 


Return to User Forum

Who is online

Users browsing this forum: No registered users and 20 guests

cron