Column Problem in Shopping Cart custom template

General ShopSite user discussion

Column Problem in Shopping Cart custom template

Postby Steve » Tue Jun 28, 2005 8:37 am

Somehow when working in the custom design I have done something to
prevent multiple columns from working. Any ideas?

Here is the cart:
http://www.strokersdallas.com/store/

thanks
Steve
 

Re: Column Problem in Shopping Cart custom template

Postby jim » Tue Jun 28, 2005 9:45 pm

A couple of ideas.

Make sure you are either using the Page.columns value to specify how
many columns or are using a hard coded value for the number of columns.
[-- LOOP PRODUCTS PAGE.Columns --] or
[-- LOOP PRODUCTS number --] Where number is how many columns you want,
ie. 2,3,4

Make sure you have the correct table layout for the products. ShopSite
will put in the end and start </tr><tr> tags when the specified number
of products have been put on a row but your template needs to start the
table and the initial <tr> tag. The <td> tags for a product can either
be in the product template or in the page template depending on how you
have it layed out.

Here is simple example from the help on page
http://www.shopsite.com/templates/examp ... ducts.html
----------------
<table border="[-- VAR.border --]">
[-- LOOP PRODUCTS PAGE.Columns --]
<td valign="top" align="[-- VAR.align --]">[-- PRODUCT --]</td>
[-- END_LOOP PRODUCTS --]
</table>

In case you haven't found it yet the custom template cheatsheet comes in
handy for syntax of various tags.
http://shopsite.com/help/7.1/en-US/temp ... sheet.html

Jim

Steve wrote:
Somehow when working in the custom design I have done something to
prevent multiple columns from working. Any ideas?

Here is the cart:
http://www.strokersdallas.com/store/

thanks
jim
 


Return to User Forum

Who is online

Users browsing this forum: Bing [Bot] and 15 guests