ShopSite Pro 7.1.1 - PREVNEXT tag

This is an archive of old posting to the User Forum

ShopSite Pro 7.1.1 - PREVNEXT tag

Postby Big Mike » Thu Nov 25, 2004 8:39 am

Just curious as to the proper formatting and use of the PREVNEXT template
tag.

I get the page to display the full string of page links fine via Pagination,
however, the links will not break up into groups using the "Number Of Page
Links Shown Per Page" option now available in version 7.1.1 on the Publish
screen.

I am currently using the tag [-- PREVNEXT --] alone with nothing else.
Should there be more to it?

Thank you in advance
Big Mike
 

Re: ShopSite Pro 7.1.1 - PREVNEXT tag

Postby jim » Thu Nov 25, 2004 9:42 am

Under Utilities > Publish > there are 2 settings dealing with pagination
of the store. The first setting is the maximum number of pages to
generate and the second is how many links will display on the page.
You probably need to set the second option which is new in 7.1.

Jim


Big Mike wrote:
Just curious as to the proper formatting and use of the PREVNEXT template
tag.

I get the page to display the full string of page links fine via Pagination,
however, the links will not break up into groups using the "Number Of Page
Links Shown Per Page" option now available in version 7.1.1 on the Publish
screen.

I am currently using the tag [-- PREVNEXT --] alone with nothing else.
Should there be more to it?

Thank you in advance

jim
 

Re: ShopSite Pro 7.1.1 - PREVNEXT tag

Postby Big Mike » Thu Nov 25, 2004 8:48 pm

Thanks but there were no problems in that area. Everything is set. Don't
know why it does not split into the groups. Anyone else?

"jim" <jstavast@xmission.com> wrote in message
news:co4ug8$nr2$1@eval.shopsite.com...
Under Utilities > Publish > there are 2 settings dealing with pagination
of the store. The first setting is the maximum number of pages to
generate and the second is how many links will display on the page.
You probably need to set the second option which is new in 7.1.

Jim


Big Mike wrote:
Just curious as to the proper formatting and use of the PREVNEXT
template
tag.

I get the page to display the full string of page links fine via
Pagination,
however, the links will not break up into groups using the "Number Of
Page
Links Shown Per Page" option now available in version 7.1.1 on the
Publish
screen.

I am currently using the tag [-- PREVNEXT --] alone with nothing
else.
Should there be more to it?

Thank you in advance

Big Mike
 

Re: ShopSite Pro 7.1.1 - PREVNEXT tag

Postby jim » Thu Nov 25, 2004 11:21 pm

What is the URL for the store page that should have the links? Do you
have a Pro, Manager or Starter level store? Do you have enough products
assigned to the pages so they should divide into multiple groups? If
you switch to one of the ShopSite provided page templates do the links
appear correctly? How does the code in your template compare to the
ShopSite provided templates?
Here is the code from the ShopSite tab template
[-- IF PAGE.ProductsPerPage "0" --]
# do nothing
[-- ELSE --]
<tr>
<td align="center">
<div class="footer">[-- PREVNEXT --]</div>
</td>
</tr>
[-- END_IF --]
It does generate multiple links with the output similar to this
"PrevSet Prev 3 4 5 Next NextSet" when the option is set to 3 links to
be displayed on a page.

Jim

Big Mike wrote:
Thanks but there were no problems in that area. Everything is set. Don't
know why it does not split into the groups. Anyone else?

"jim" <jstavast@xmission.com> wrote in message
news:co4ug8$nr2$1@eval.shopsite.com...

Under Utilities > Publish > there are 2 settings dealing with pagination
of the store. The first setting is the maximum number of pages to
generate and the second is how many links will display on the page.
You probably need to set the second option which is new in 7.1.

Jim


Big Mike wrote:

Just curious as to the proper formatting and use of the PREVNEXT

template

tag.

I get the page to display the full string of page links fine via

Pagination,

however, the links will not break up into groups using the "Number Of

Page

Links Shown Per Page" option now available in version 7.1.1 on the

Publish

screen.

I am currently using the tag [-- PREVNEXT --] alone with nothing

else.

Should there be more to it?

Thank you in advance




jim
 

Re: ShopSite Pro 7.1.1 - PREVNEXT tag

Postby Big Mike » Fri Nov 26, 2004 12:51 pm

Thanks again.... Yes, Pro version and we have more than enough products
with 5000 site wide. Maybe 100 to 400 per page/category where we are
assigning 30 products per page via Pagination. The pages and PREV / NEXT
links are created fine, they just will not group into the PREV & NEXT sets.
We get all the links in one long html string which wouldn't be a problem at
all if the SHOPSITE SCRIPT DIDN'T INSERT NOBREAK TAGS. If the NOBREAK tags
were not used in between each <A HREF code, the link html string would
just wrap and not force our HTML page/tables to CONTINUE OFF THE USER'S
SCREEN. HINT TO SHOPSITE BY THE WAY!!!.

We even tried to find the compiled CGI file that controls this to remove the
NOBREAK tag, but we can not find this file for the life of us. Anyone know
which CGI file controls this????

Anyhow, the site is adult oriented so I will opt not to publish any links to
the site from the shopsite forum. Yes, we viewed that template and used the
IF and ELSE statements as well but there were no changes.... ????


"jim" <jstavast@xmission.com> wrote in message
news:co6eg4$q0$1@eval.shopsite.com...
What is the URL for the store page that should have the links? Do you
have a Pro, Manager or Starter level store? Do you have enough products
assigned to the pages so they should divide into multiple groups? If
you switch to one of the ShopSite provided page templates do the links
appear correctly? How does the code in your template compare to the
ShopSite provided templates?
Here is the code from the ShopSite tab template
[-- IF PAGE.ProductsPerPage "0" --]
# do nothing
[-- ELSE --]
tr
td align="center"
div class="footer">[-- PREVNEXT --]</div
/td
/tr
[-- END_IF --]
It does generate multiple links with the output similar to this
"PrevSet Prev 3 4 5 Next NextSet" when the option is set to 3 links to
be displayed on a page.

Jim

Big Mike wrote:
Thanks but there were no problems in that area. Everything is set. Don't
know why it does not split into the groups. Anyone else?

"jim" <jstavast@xmission.com> wrote in message
news:co4ug8$nr2$1@eval.shopsite.com...

Under Utilities > Publish > there are 2 settings dealing with pagination
of the store. The first setting is the maximum number of pages to
generate and the second is how many links will display on the page.
You probably need to set the second option which is new in 7.1.

Jim


Big Mike wrote:

Just curious as to the proper formatting and use of the PREVNEXT

template

tag.

I get the page to display the full string of page links fine via

Pagination,

however, the links will not break up into groups using the "Number Of

Page

Links Shown Per Page" option now available in version 7.1.1 on the

Publish

screen.

I am currently using the tag [-- PREVNEXT --] alone with nothing

else.

Should there be more to it?

Thank you in advance




Big Mike
 

Re: ShopSite Pro 7.1.1 - PREVNEXT tag

Postby jim » Fri Nov 26, 2004 5:51 pm

Try creating a test page, assign it the ShopSite Rounded template and
set the number of products per generated page as you have for other
pages. Then assign a bunch of products to it and use the Page > Preview
feature to see if the links show the PrevSet and NextSet links and if
they work.
If that works then there maybe problem with your template. If it doesn't
work then something isn't configured properly. If you would like send a
copy of the template to me and I'll try it on another store to see if
the problem occurs there.

If this doesn't resolve the issue then you should probably escalate this
through your ISP or if they don't provide support, purchase a support
insident from ShopSite to have them look into it. You can request
direct support at http://shopsite.com/support_pricing.html.

Jim

Big Mike wrote:
Thanks again.... Yes, Pro version and we have more than enough products
with 5000 site wide. Maybe 100 to 400 per page/category where we are
assigning 30 products per page via Pagination. The pages and PREV / NEXT
links are created fine, they just will not group into the PREV & NEXT sets.
We get all the links in one long html string which wouldn't be a problem at
all if the SHOPSITE SCRIPT DIDN'T INSERT NOBREAK TAGS. If the NOBREAK tags
were not used in between each <A HREF code, the link html string would
just wrap and not force our HTML page/tables to CONTINUE OFF THE USER'S
SCREEN. HINT TO SHOPSITE BY THE WAY!!!.

We even tried to find the compiled CGI file that controls this to remove the
NOBREAK tag, but we can not find this file for the life of us. Anyone know
which CGI file controls this????

Anyhow, the site is adult oriented so I will opt not to publish any links to
the site from the shopsite forum. Yes, we viewed that template and used the
IF and ELSE statements as well but there were no changes.... ????


"jim" <jstavast@xmission.com> wrote in message
news:co6eg4$q0$1@eval.shopsite.com...

What is the URL for the store page that should have the links? Do you
have a Pro, Manager or Starter level store? Do you have enough products
assigned to the pages so they should divide into multiple groups? If
you switch to one of the ShopSite provided page templates do the links
appear correctly? How does the code in your template compare to the
ShopSite provided templates?
Here is the code from the ShopSite tab template
[-- IF PAGE.ProductsPerPage "0" --]
# do nothing
[-- ELSE --]
tr
td align="center"
div class="footer">[-- PREVNEXT --]</div
/td
/tr
[-- END_IF --]
It does generate multiple links with the output similar to this
"PrevSet Prev 3 4 5 Next NextSet" when the option is set to 3 links to
be displayed on a page.

Jim

Big Mike wrote:

Thanks but there were no problems in that area. Everything is set. Don't
know why it does not split into the groups. Anyone else?

"jim" <jstavast@xmission.com> wrote in message
news:co4ug8$nr2$1@eval.shopsite.com...


Under Utilities > Publish > there are 2 settings dealing with pagination
of the store. The first setting is the maximum number of pages to
generate and the second is how many links will display on the page.
You probably need to set the second option which is new in 7.1.

Jim


Big Mike wrote:


Just curious as to the proper formatting and use of the PREVNEXT

template


tag.

I get the page to display the full string of page links fine via

Pagination,


however, the links will not break up into groups using the "Number Of

Page


Links Shown Per Page" option now available in version 7.1.1 on the

Publish


screen.

I am currently using the tag [-- PREVNEXT --] alone with nothing

else.


Should there be more to it?

Thank you in advance






jim
 

Re: ShopSite Pro 7.1.1 - PREVNEXT tag

Postby Big Mike » Sat Nov 27, 2004 2:11 am

I will have to contact support. I will add this next piece to the thread in
case anyone has the same problem. I did use the Rounded template and still
the same problem. However, one thing I forgot to mention is, if I edit an
individual page and hit publish, it will display the PREVNEXT sets. But if I
use the Regenerate action after that at some point. It will resort back to
the complete string of links again with no sets.

????????

"jim" <jstavast@xmission.com> wrote in message
news:co8fhv$42r$1@eval.shopsite.com...
Try creating a test page, assign it the ShopSite Rounded template and
set the number of products per generated page as you have for other
pages. Then assign a bunch of products to it and use the Page > Preview
feature to see if the links show the PrevSet and NextSet links and if
they work.
If that works then there maybe problem with your template. If it doesn't
work then something isn't configured properly. If you would like send a
copy of the template to me and I'll try it on another store to see if
the problem occurs there.

If this doesn't resolve the issue then you should probably escalate this
through your ISP or if they don't provide support, purchase a support
insident from ShopSite to have them look into it. You can request
direct support at http://shopsite.com/support_pricing.html.

Jim

Big Mike wrote:
Thanks again.... Yes, Pro version and we have more than enough
products
with 5000 site wide. Maybe 100 to 400 per page/category where we are
assigning 30 products per page via Pagination. The pages and PREV / NEXT
links are created fine, they just will not group into the PREV & NEXT
sets.
We get all the links in one long html string which wouldn't be a problem
at
all if the SHOPSITE SCRIPT DIDN'T INSERT NOBREAK TAGS. If the NOBREAK
tags
were not used in between each <A HREF code, the link html string would
just wrap and not force our HTML page/tables to CONTINUE OFF THE USER'S
SCREEN. HINT TO SHOPSITE BY THE WAY!!!.

We even tried to find the compiled CGI file that controls this to remove
the
NOBREAK tag, but we can not find this file for the life of us. Anyone
know
which CGI file controls this????

Anyhow, the site is adult oriented so I will opt not to publish any
links to
the site from the shopsite forum. Yes, we viewed that template and used
the
IF and ELSE statements as well but there were no changes.... ????


"jim" <jstavast@xmission.com> wrote in message
news:co6eg4$q0$1@eval.shopsite.com...

What is the URL for the store page that should have the links? Do you
have a Pro, Manager or Starter level store? Do you have enough products
assigned to the pages so they should divide into multiple groups? If
you switch to one of the ShopSite provided page templates do the links
appear correctly? How does the code in your template compare to the
ShopSite provided templates?
Here is the code from the ShopSite tab template
[-- IF PAGE.ProductsPerPage "0" --]
# do nothing
[-- ELSE --]
tr
td align="center"
div class="footer">[-- PREVNEXT --]</div
/td
/tr
[-- END_IF --]
It does generate multiple links with the output similar to this
"PrevSet Prev 3 4 5 Next NextSet" when the option is set to 3 links to
be displayed on a page.

Jim

Big Mike wrote:

Thanks but there were no problems in that area. Everything is set.
Don't
know why it does not split into the groups. Anyone else?

"jim" <jstavast@xmission.com> wrote in message
news:co4ug8$nr2$1@eval.shopsite.com...


Under Utilities > Publish > there are 2 settings dealing with
pagination
of the store. The first setting is the maximum number of pages to
generate and the second is how many links will display on the page.
You probably need to set the second option which is new in 7.1.

Jim


Big Mike wrote:


Just curious as to the proper formatting and use of the PREVNEXT

template


tag.

I get the page to display the full string of page links fine via

Pagination,


however, the links will not break up into groups using the "Number Of

Page


Links Shown Per Page" option now available in version 7.1.1 on the

Publish


screen.

I am currently using the tag [-- PREVNEXT --] alone with nothing

else.


Should there be more to it?

Thank you in advance






Big Mike
 


Return to User Forum Archive

Who is online

Users browsing this forum: Bing [Bot] and 4 guests

cron