SS Pro v12 Upgrade Internal Server Error

General ShopSite user discussion

SS Pro v12 Upgrade Internal Server Error

Postby ihssaplesk » Wed May 23, 2018 8:20 am

Upgrading Shopsite Pro v11 SP2 R4.3 to V12 SP3 R4
- Loading wwwinstall.cgi in browser to upgrade. Getting Internal Server Error right off the bat.
- Permissions on wwwinstall.cgi are 755.
- wwwinstall.cgi owner and group are same as the last Shopsite upgrade.
- The error_log logged errors:
Inconsistency detected by ld.so: dynamic-link.h: 62: elf_get_dynamic_info: Assertion `! "bad dynamic tag"' failed!
Premature end of script headers: wwwinstall.cgi
- Launched wwwinstall.cgi from command line: Inconsistency detected by ld.so: dynamic-link.h: 62: elf_get_dynamic_info: Assertion `! "bad dynamic tag"' failed!
- The hardware of server is 32-bit. I uploaded the 32-bit version.
- The file size of the uploaded wwwinstall.cgi and local file are the same.

In testing I launched the previous wwwinstall.cgi from 2016 and it loaded OK in the browser.
ihssaplesk
 
Posts: 18
Joined: Fri Jan 17, 2014 11:08 am

Re: SS Pro v12 Upgrade Internal Server Error

Postby loren_d_c » Wed May 23, 2018 2:52 pm

First, if you uploaded wwwinstall.cgi to the server via FTP, make sure that you are doing so in Binary FTP mode, doing it in ASCII/Text mode or 'Auto' letting the FTP app decide could end up corrupting the file.

Next, check the glibc version on your server. ShopSite 11 sp2 only required glibc 2.1 or newer, but ShopSite 12 sp2 and newer requires glibc 2.5 (for the 32-bit version).

-Loren
loren_d_c
 
Posts: 2521
Joined: Fri Aug 04, 2006 12:02 pm
Location: Anywhere

Re: SS Pro v12 Upgrade Internal Server Error

Postby ihssaplesk » Thu May 24, 2018 9:26 am

Did already FTP manually specifying BINARY for wwwinstall.cgi - that is usually the culprit.
Had a suspicion it was the glibc version on this server. We upgraded two SS Pro last year on a different server without this issue. Compared the two new libs used in V12 on OK server versus problem server and the version IS less than 2.5.

Problem Server
librt.so.1 (libc6, OS ABI: Linux ) => /lib/librt.so.1
librt.so (libc6, OS ABI: Linux 2.0.30) => /usr/lib/librt.so
libpthread.so.0 (libc6, OS ABI: Linux 2.0.30) => /lib/libpthread.so.0

Server on which ShopSite Pro v12 upgraded OK:
librt.so.1 (libc6, OS ABI: Linux 2.6.24) => /lib32/librt.so.1
libpthread.so.0 (libc6, OS ABI: Linux 2.6.24) => /lib32/libpthread.so.0

Will need to move the website to another ISP/hosting company. Not feasible to update the glibc on this 2005 server. Will be reviewing the instructions for moving a Shopsite install to a new web host server, then upgrade there. Any tips for that?
ihssaplesk
 
Posts: 18
Joined: Fri Jan 17, 2014 11:08 am

Re: SS Pro v12 Upgrade Internal Server Error

Postby ihssaplesk » Wed May 30, 2018 10:03 am

Please - One more question on this issue for us.
I believe that glibc version is 2.2.5 from the results of ldd --version below, correct?

# ldd --version
ldd (GNU libc) 2.2.5
Copyright (C) 2002 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
Written by Roland McGrath and Ulrich Drepper.

If correct, then is the real culprit the Debian kernel version on this server?
# uname -a
Linux ibox 2.4.28 #2 SMP Wed Jan 26 19:26:50 MST 2005 i686 unknown
ihssaplesk
 
Posts: 18
Joined: Fri Jan 17, 2014 11:08 am

Re: SS Pro v12 Upgrade Internal Server Error

Postby loren_d_c » Wed May 30, 2018 12:49 pm

No, kernel version really doesn't matter so much. glibc 2.2.5 is OLDER than glibc 2.5, so that is the issue.

-Loren
loren_d_c
 
Posts: 2521
Joined: Fri Aug 04, 2006 12:02 pm
Location: Anywhere


Return to User Forum

Who is online

Users browsing this forum: ShopSite David and 5 guests

cron