Paypal TLS 1.2

General ShopSite user discussion

Paypal TLS 1.2

Postby kiltym » Thu May 24, 2018 10:48 am

My understanding is that V12SP2 is up to date and uses TLS 1.2.

However I keep getting emails/message from Paypal. Can I safely ignore these?

Thank you.
kiltym
 
Posts: 38
Joined: Tue Dec 08, 2009 12:00 pm
Location: MA

Re: Paypal TLS 1.2

Postby ShopSite David » Fri May 25, 2018 9:07 am

If you are running version 12 sp2 r4 then you should be good to go with PayPal (note the r4 in the version.) You can check your version at the bottom left of the main ShopSite screen (start.cgi) or from the Help in the Navigation select About ShopSite. For more information on TLS 1.2 see this knowledgebase article:

http://support.shopsite.com/KBase/questions/2581
-David H.
ShopSite, Inc.
http://www.shopsite.com
ShopSite David
Site Admin
 
Posts: 235
Joined: Fri Aug 04, 2006 1:30 pm
Location: Utah

Re: Paypal TLS 1.2

Postby kiltym » Thu May 31, 2018 10:13 am

Hi David,

Thanks,

We are running SP2. There is no r anything after it.

The SS release notes states SP2 has TLS1.2 support. Is that incorrect? When did "r4" appear in the world as we have been under the assumption (based on Shoptsite documentation), that what we were running was fine. Now it's not?


None of our payments are working right now. Paypal Express gives a 500 error, and we use Paypal Payflow Pro for credit cards, and now all of a sudden all we get back is "Payment Processing Error
Your order was not processed

There was a problem processing your credit card information.
Please verify that the following were entered correctly:

Zip Code
Card Number
Expiration Date

If you repeatedly see this message, complete your order by contacting The Wirie directly at support@thewirie.com or (617) 819-4743. Thank you, and sorry for the inconvenience."

from SS. But there is no record of the attempt on Paypal about it so I am pretty sure the request is not making it off our servers.....

http://www.shopsite.com/blog/2015/10/new-shopsite-release-v12-service-pack-2/

How do I find our a real error message about what is going on so I can fix our website.

Thank you,
kiltym
 
Posts: 38
Joined: Tue Dec 08, 2009 12:00 pm
Location: MA

Re: Paypal TLS 1.2

Postby kiltym » Thu May 31, 2018 10:15 am

I turned on Display Error Details and Detail Verbosity to Medium, and I get this, which is neither detailed nor verbose.....

"Detailed error message:
-1: "


Where and how can I find out what is going on?
kiltym
 
Posts: 38
Joined: Tue Dec 08, 2009 12:00 pm
Location: MA

Re: Paypal TLS 1.2

Postby ShopSite David » Thu May 31, 2018 11:02 am

Looks like you have been talking directly to us. I understand you'll first try the upgrade to v12 sp3 and see if that resolves anything. My guess is that it will not since PayPal is not fully requiring TLS 1.2 until the end of June. But, maybe it will. If not, we'll need access to your site to trouble-shoot.
-David H.
ShopSite, Inc.
http://www.shopsite.com
ShopSite David
Site Admin
 
Posts: 235
Joined: Fri Aug 04, 2006 1:30 pm
Location: Utah


Return to User Forum

Who is online

Users browsing this forum: No registered users and 7 guests